GIMP Troubleshooting

When Things Aren’t Working You Need GIMP Help

Every new GIMP user will need GIMP help at some point. As you use GIMP, you may have some questions about what a term means, what a tool does, why a tool won’t work as expected, or how to preform really basic tasks like drawing a straight line.

Many of these quirks and questions are addressed on this page. I’ll explain some of GIMP’s technical terms in plain English, I’ll cover some of the more common but frustrating problems you might encounter while using GIMP (good news- they’re super easy to fix!), and I’ll cover some common How To questions that will help make your first days of using GIMP a little easier.

Click on a link below to reveal more information without leaving this page. Click the link again to show less.

What Does This Term Mean?

There are some terms and tool options in GIMP that you may not be able to figure out at first glance. Thankfully, these complicated sounding words usually have pretty simple meanings. I’ve listed a few below, and remember there is a Glossary at the end of the How to GIMP book to help you with even more GIMP and photography terms.

GIMP Tools Not Working

The good news is, when tools don’t work in GIMP the solution is usually pretty simple.

Think of the following help section as a cheat sheet for troubleshooting your GIMP tool problems quickly.

How Do I..? GIMP Basics Help

More Help

If you need help with your How to GIMP purchase, please see the Help Page.

If you need more GIMP Help, there are even more solutions to your problems listed in the FAQ and there are more GIMP basics in the GIMP Tutorials section of HowToGIMP.com.

A dialog is a window that contains options and settings for a tool or function in GIMP. Some of these dialogs can be docked (or attached) to other windows, like the Toolbox Window, making the dialogs and their options easily accessible when you need them.

There are instructions for docking the Layers Dialog to the Toolbox window in Chapter Two of the How to GIMP book, and two troubleshooting videos on docking dialogs on this page under “Troubleshoot Docking Dialogs”.

Alpha sounds like a math term, but in GIMP it just means transparency.

For example, If you go to Colors > Color to Alpha you’ll be taken to a window that lets you change any color in the image to transparent pixels. “Color to Alpha” really means “change color to transparency”.

If you are working with a layer and the Layer Mask option is grayed out, or the Eraser Tool isn’t working properly you may need to add an Alpha Channel to that layer. Adding an Alpha Channel to a layer turns on the layer’s ability to use transparent pixels.

Again, sounds like it could be a complicated term, but Delta really just means difference.

In GIMP, difference often means the contrast between pixels, since contrast can be described as the difference between light and dark. A white pixel next to a black pixel has a lot of contrast, but two middle gray pixels are less different, so we say they have less contrast.

You might encounter the term Max Delta when you’re using certain filters in GIMP, for example the Selective Gaussian Blur filter.

In this case Max Delta means the Maximum Difference or maximum contrast.

The Selective Gaussian Blur filter will only blur portions of the photo that have less contrast than your Max Delta setting. Pixels that have more contrast (or more difference) than the Max Delta setting will not be blurred.

A Threshold is a limit. You’ll see this term when you’re using some filters and tools, like the Fuzzy Select (Magic Wand) Tool.

The Threshold setting for a tool or filter is usually the limit at which the tool or filter will no longer take effect.

For example, the Fuzzy Select Tool selects regions of a photo or image that have similar colors. Setting the Threshold option for the Fuzzy Select Tool to a very low number limits the selection to very similar colors. Setting the Threshold option higher means the range of colors is less limited, so the selection will include a broader range of less similar colors.

There is also a Threshold adjustment that’s under the Color section of the Main Menu, but its use is beyond the scope of the book and this website. You can learn more about the Threshold Adjustment here.

This is probably caused by one of two things.

1. The dialog may have popped up, but it’s hidden underneath another window. Move or minimize the Main Window to make sure the dialog you chose didn’t pop up behind it.

2. The other possibility happens if the dialog you chose is already docked to a window like the Toolbox, or the Layers/Channels/Paths Docking Window.

If you don’t see the dialog hidden underneath another window, it’s probably already docked somewhere. Now, we just have to do a little detective work to find it:

  • If the dialog is docked to a window that you can see, when you go to Windows > Dockable Dialogs and choose your dialog, a black outline will blink a couple of times around the dialog. This lets you know where the dialog is already docked. There’s an example of this in the video on docking dialogs for GIMP 2.8, under the Troubleshoot Docking Dialogs section below.
  • If you don’t see that blinking outline, that probably means that the window the dialog is docked to is hidden. It might be minimized, it might be hidden behind another window, or it may have been hidden within the Main Window if you’re using Single Window Mode.
  • If you’re not using Single Window Mode (which is only available in GIMP 2.8 and up) check to see if you have any GIMP windows minimized, or hidden behind another window. If you do, maximize the window, or drag it to the front, and look for your missing dialog in that window. You can try going to Windows > Dockable Dialogs and clicking on the dialog you’re looking for to see if there is a blinking outline around your missing dialog.
  • If you are using Single Window Mode, and you hid any sections of the window by sliding them to the left or right, you can reveal them again by looking for a column of dots on either side of the Main Window, then hovering your mouse over the column of dots. when your mouse turns into a two way arrow with a bar in the middle (pictured below) click and drag the column of dots inward to reveal the hidden section of the window.

gimp help

I recommend docking the Layers Dialog and the Tool Options Dialog to the Toolbox at the beginning of How to GIMP to help make GIMP easier to use. This makes the most used dialogs in the book (and in my free GIMP tutorials) handy in the Toolbox. And since you won’t need the other dialogs that often, you can close or hide the extra third window to un-clutter your GIMP interface.

A common problem, though, is not being able to dock the Layers Dialog (or any dialog) to the Toolbox. The problem is almost always very simple to fix. I’ve found it’s a lot more helpful for people to watch this process in action than it is for you to read about it, so I’ve made a couple of videos to help you with the GIMP dialog docking process.

How to Dock GIMP’s Dialogs

how to dock gimp dialogs

Extra Help Docking Dialogs

how to dock gimp dialogs

If the Eraser Tool is painting instead of erasing, you probably need to add an “Alpha Channel” to the layer you’re working on.

  • First, Go to the Layers Dialog (learn how to find the Layers Dialog in Chapter Two of the book, and in the link above on Troubleshooting Docking Dialogs).
  • Now, look for the correct Layer Thumbnail. It will look like a mini version of the image you have open, or the layer you want to work on.
  • Right-click (or alternate click using your preferred method if you’re on a Mac) on that layer thumbnail. A menu of options will appear.
  • Choose “Add Alpha Channel” from the list of options.
  • The Alpha Channel will be added to your image, and the eraser should work as expected now

There are many reasons a tool in GIMP won’t work. If you’re already fairly fluent in GIMP, you can try the following quick suggestions for the most likely culprits. Don’t worry, I’ll go over them in more detail in case you need more help.

Quick Checklist

  • Make sure the correct layer is active in the layers dialog.
  • Make sure the active layer is visible.
  • Make sure there isn’t a selection on the image.
  • Make sure the tool has usable settings.
  • Make sure you’re trying to edit an editable area (IE you’re trying to use the tool on the image, not GIMP’s “padding”).

Here are those suggestions in more detail.

Make Sure the Correct Layer is Active and Visible

If You don’t know what a layer is, you probably don’t have more than one layer in your image, and you can skip this suggestion and move on to suggestion two.

If you do know what layers are, and you have more than one layer in your image, go to the Layers Dialog and make sure the correct layer is highlighted.

While you’re in the Layers Dialog, make sure that the layer you want to edit is visible. If you don’t see a little eye button next to the layer’s thumbnail, click in the area to the left of the thumbnail to make the eye appear, and make the layer visible. If that was the problem, you should see your edits now.

Along the same lines, you should make sure that the layer you’re editing has some opacity. Highlight the layer you want to edit in the Layers Dialog, and make sure the Opacity Slider isn’t set to 0. If it’s not 0 but it’s still very low you still may not see your edits so you may want to set the slider to 100. If you can see the edits now, the opacity of the layer was set too low.

Check Your Selections

If there is a selection on an image, GIMP’s tools only work within that selection. That means if you made a selection and you’re trying to use a tool outside of that selection, the tool won’t work.

You may not even see the marching ants around the selection, because you might have accidentally made a tiny selection. So, it’s a good idea to try the following suggestion even if you don’t think you have a selection on your image.

  • If you know you have a selection, and you want to save it to use again later, go to Select > To Path to save the selection as a path. Later, when you want to use the selection again you can open the Paths Dialog (Windows > Dockable Dialogs > Paths) choose the correct path from the dialog, then go to Select > From Path to turn the saved path into a selection.
  • Once the selection is saved (or if you don’t want to save the selection) go to Select > None in the Main Menu.This will delete any active selection on the image (your path will be safe and sound if you followed the first step).
  • If this was the problem, your tools should work as expected now. If not, move on to the next suggestion.

Make Sure the Tool Has Usable Settings

This could be as simple as going to the Tool Options Dialog and making sure the Tool’s opacity isn’t set to 0. If the tool’s opacity is set to 0 (or it’s very low) the tool may be too weak for you to see the changes it’s making. Try setting the tool’s opacity to 100%. If the tool works, its opacity was set too low.

The problem could be a little more complex, though. For example, if you use the Clone Stamp Tool, you can’t stamp until you set a source to clone from, by holding Ctrl and clicking on the image.

In a case like that, where the tool isn’t usable until you take some specific action, there will be a message telling you what the problem is at the bottom of the Main Window as you hover your mouse over the image. In the Clone Tool example, the message you see is “Ctrl-Click to Set a New Clone Source”.

If you don’t understand the message, try typing the message plus the word “GIMP” into your favorite search engine. A web page with the instructions for using that tool or solving that error message will likely be in the first few search results.

Since each tool has its own settings, I can’t cover them all here. As you work through the book, you’ll read more about many of GIMP’s tools and their setting options. And, there is more help for tool options listed in the How to GIMP glossary and other appendices.

Make sure You’re Trying to Edit and Editable Area

GIMP’s tools only work on images, whether that’s a photo that you opened, or a new image that you created by going to File > New in the Main Menu. If you’re trying to use a tool on the area around the image, GIMP’s “padding”, the tool won’t work.

If you’re trying to change the color of GIMP’s padding, there is a way to do that. Instructions are on page 81 of the book.

Need more GIMP Help?

I’ve gone over the most common reasons tools decide not to work in GIMP. But, if you’ve gone through all of these suggestions and the problem still isn’t solved, please see GIMP’s official “Getting Unstuck” page for more official GIMP help.

To get rid of the current selection without saving it first:

  • Go to Select > None in the Main Menu.

If you want to save the selection before you get rid of it, you can save it as a Path (which you can turn back into a selection later).

  • To do that, first go to Select > To Path.
  • You can check that your selection was saved as a path by going to Windows > Dockable Dialogs > Paths in the Main Menu to open the Paths Dialog. You can dock this dialog to the Toolbox if you want to keep your saved paths handy.
  • Then go to Select > None to remove the active selection from the image.
  • Now, if you want to re-activate the selection, go to the Paths Dialog, highlight the correct path, then go to Select > From Path in the Main Menu. The path will be turned into a selection.

Go to View > Show Layer Boundaries in the Main Menu. The yellow dotted layer boundary line will disappear.

There’s no “line tool” in GIMP. That might be frustrating if you’re familiar with image editing programs that do have a tool like that. But, once you know how easy it is to make a straight line in GIMP without having to grab a different tool as you paint, you’ll never look back.

  • Grab a paint tool like the Pencil, or Paintbrush.
  • Choose the appropriate tool settings for the brush in the Tool Options Dialog.
  • Click the first point of the line in Main Window, then hold down the Shift button on your keyboard, and move your mouse to over the image to the point you would like the line to end.
  • You’ll see a straight “guide” line appear as you move your mouse to let you know where the line will be drawn.
  • Now, click the end point of the line. The line will be drawn on the picture between the start and end points that you clicked.

See? Click, hold Shift, Click again. Super easy.